[Coco] OS-9 / NOS-9

Chester A Patterson vchester at setec-cr.com
Fri Oct 13 12:47:01 EDT 2006

The rig worked as is perfectly 12 years ago (CC3-512, MPI, B&B XT
Interface with DTC-5150, CRC mini FDC, Teac 5.25" 360k, Sony 3.5" 720k)
I had it booting from the ST225 no problems (B&B XT ROM) The BBFhdisk I
took from the original release disk (I have original release disks for
several B&B OS9 products, unfortunately RSB went belly up though)  The
/H0 descriptor is the one I made 16-17 years ago with ddmaker that
worked perfectly then, and works perfectly now under OS9L2. Ident shows
no problems either under OS9 or NOS9 for the driver and descriptors.
Under OS9 we used to load BBFhdisk and descriptors all the time, just to
test drive systems we put together (we sold many) and this worked fine.
Just to format and test access. For permanent installations we ezgen'd
the dr/dd combo in right after RBF. Which is what I want to do with
NOS9. I wanted to test how it worked before doing this, hence the loads,
which give me "No Permission" Drat!

The NOS9 version I downloaded fresh a couple of months ago. I'll recheck
that Burke directory thing, I know I ident'd a module in there to see if
it was BBFHdisk and a generic descriptor but it was a single module, so
I don't know what it is, perhaps a driver for something else.

The ST225 I had to re-format (horrors! I lost so much there) some months
ago when I first fired up the rig after a dozen years. It reported and
continues to report no errors or problems. Runs great under OS9 (just
those dang seek and read errors all the time with the floppies, is
really why I need to move completely to NOS9 ASAP)

I religously park my ST225 after every session.

I thought perhaps something to do with the revision level? Or could it
be the date?

-----Original Message-----
From: Robert Gault [mailto:robert.gault at worldnet.att.net] 
Sent: Friday, October 13, 2006 8:29 AM
To: CoCoList for Color Computer Enthusiasts
Subject: Re: [Coco] OS-9 / NOS-9

Chester A Patterson wrote:
> Hello. Have ST-225 Burke and Burke system, CC3-512k, MPI, CRC mini 
> controller.
> OS9 gives me seek and read FDD errors all the time. NOS9 does not.
> Must be that BLOB thing discussed here some time ago. Never had that 
> problem before!
> I Boot NOS9 from 3.5" 720kb (made on a 1.44 PC FDD) Just to see if I 
> can access /H0, I try to load bbfhdisk.dr and H0_ST225.dd from /D1 but

> get No Permission error. Attr on both files is --e-w-ewr Why won't 
> they load? How to solve this?
> I notice in the NOS9 directories on the boot disk that there is a 
> module named Burke.
> What is the purpose of this file?
> I DO plan to move to all the new hardware eventually, however I really

> want to make certain I can get this old rig up and running, and get 
> re-accostomed to working with a Coco after over a decade.
> I've got several other hardware problems but right now this is the 
> main one.
> I appreciate your help! Thanks.
> /Chester

Please specify which version of NitrOS-9 you are using. It reads like an
original Gale Force v1.22 rather than any current version from

If it is an original version, Burke is not a module but a directory
containing several bbfhdisk.dr drivers.

There are several issues here. 1) Will the CRC controller work with the
B&B hard drive system? Do you additionally have a B&B controller and
have selected the correct driver for it?
2) You can't just separately load bbfhdisk.dr and H0_ST225.dd and expect
them to work. At the very least, they must be merged into a single file
with the e pe attributes set. Are you sure that H0_ST225.dd is the
correct descriptor for the bbfhdisk.dr driver?

More information about the Coco mailing list