[Coco] Hard Drive Problems

Frederick D Provoncha elderpav at juno.com
Wed Jun 9 00:47:36 EDT 2004

Hi Mark,

I'm running NitrOS-9 version 2.0.

I'm not sure where to find the SCSI hard drive boot ID, but I have TC^3
version 1.0. The driver is the TC^3 SCSIsys  driver, NOT the SuperSCSI

I DO have access to the scripts, at least the ones that came with my
NitrOS-9 version 2.0 setup. I backed up all of those directories onto
floppies. The script I used to create the boot that resides on Drive 255
is a modified version of the 'make_rgbboot' script.

The thing is though, I already have a working floppy boot disk. I can
boot NitrOS-9 version 2.0 from a floppy just fine. It's just whenever I
try looking at the hard drive after booting, the system hangs.

Please forgive my ignorance, but what is SCSIcmds? Whatever it is, I
don't think I have it...

Fred Provoncha

On Mon, 07 Jun 2004 06:46:01 -0500 Mark Marlette <mmarlett at isd.net>
> At 09:34 PM 6/6/2004 -0600, you wrote:
> Fred,
> Please describe what your system is. As I recall I built it, 
> NitrOS-9 
> version ??? SCSI hard drive boot ID=??, SuperSCSI or TC^3 driver??? 
> All the 
> systems I ship use scripts. You should have a read.me or readme.txt 
> in the 
> root explaining how to build the boots.
> So can you build a floppy boot? If you can't then don't try the hard 
> drive 
> boot. Floppy boot with SCSIcmds, can you see the drive via the 
> utility? You 
> should it it/was a working drive???
> Thanks,
> Mark
> >Hi Mark,
> >
> >I booted NitrOS-9 using an all-floppy boot that contained the /h0
> >descriptor. I then tried your suggestion of running 'dcheck /h0'. 
> The
> >system hung, which is exactly what happened when I tried a 'dir 
> /h0'
> >which I described in my last message. Whenever NitrOS-9 tries 
> looking for
> >the hard drive for any reason it can't seem to find it and it 
> hangs. This
> >only applies to the NitrOS-9 partition on the hard drive. The 
> >partition works just fine and I have full access to it.
> >
> >As for the 'mb_hdb_dd' script, I'm not running the script yet 
> because I'm
> >still running my system under an outdated version of NitrOS. 
> That's
> >because I'm still having problems transferring the latest version 
> of
> >NitrOS over to a floppy that the Coco can read. I posted a couple
> >messages about that a couple of weeks ago. I should probably give 
> you
> >guys an update on that endeavor:
> >
> >If you recall, I reported that I could not get the Coco to read a 3 
> 1/2"
> >boot disk created using DSKINI and the most-recent downloaded .dsk 
> image
> >of NitrOS. I was getting "Error 249 - Wrong Type". I tried Rodney
> >Hamilton's suggestion of using DMODE to change the DNS setting in 
> the /d1
> >drive descriptor to DNS=3. I then tried "DIR /d1" and lo and 
> behold, I
> >got a directory listing of the root directory of /d1! My euphoria 
> was
> >short-lived however, because when I tried doing directory listings 
> of the
> >sub-directories CMDS, SYS, and DEFS, the DEFS directory was fine 
> but I
> >got an "Error 214" with the CMDS directory and an "Error 247" with 
> the
> >SYS directory. It seems to me that Rodney was on the right track. 
> After
> >all, before I couldn't read the disk at all, and at least now I can 
> >the root directory successfully and the DEFS directory. But the 
> disk is
> >still basically unuseable. I have also tried Rodney's suggestion 
> of
> >alternatively patching LSN0 to change the DD.FMT value from $07 to 
> $03
> >with pretty-much the same results as the DMODE fix. Anyone else 
> have any
> >ideas?
> >
> >Fred Provoncha
> >Stansbury Park, UT
> >
> >--
> >Coco mailing list
> >Coco at maltedmedia.com
> >http://five.pairlist.net/mailman/listinfo/coco
> -- 
> Coco mailing list
> Coco at maltedmedia.com
> http://five.pairlist.net/mailman/listinfo/coco

More information about the Coco mailing list