[Coco] Hard Drive Problems

Mark Marlette mmarlett at isd.net
Mon Jun 7 07:46:01 EDT 2004

At 09:34 PM 6/6/2004 -0600, you wrote:


Please describe what your system is. As I recall I built it, NitrOS-9 
version ??? SCSI hard drive boot ID=??, SuperSCSI or TC^3 driver??? All the 
systems I ship use scripts. You should have a read.me or readme.txt in the 
root explaining how to build the boots.

So can you build a floppy boot? If you can't then don't try the hard drive 
boot. Floppy boot with SCSIcmds, can you see the drive via the utility? You 
should it it/was a working drive???



>Hi Mark,
>I booted NitrOS-9 using an all-floppy boot that contained the /h0
>descriptor. I then tried your suggestion of running 'dcheck /h0'. The
>system hung, which is exactly what happened when I tried a 'dir /h0'
>which I described in my last message. Whenever NitrOS-9 tries looking for
>the hard drive for any reason it can't seem to find it and it hangs. This
>only applies to the NitrOS-9 partition on the hard drive. The RGB-DOS
>partition works just fine and I have full access to it.
>As for the 'mb_hdb_dd' script, I'm not running the script yet because I'm
>still running my system under an outdated version of NitrOS. That's
>because I'm still having problems transferring the latest version of
>NitrOS over to a floppy that the Coco can read. I posted a couple
>messages about that a couple of weeks ago. I should probably give you
>guys an update on that endeavor:
>If you recall, I reported that I could not get the Coco to read a 3 1/2"
>boot disk created using DSKINI and the most-recent downloaded .dsk image
>of NitrOS. I was getting "Error 249 - Wrong Type". I tried Rodney
>Hamilton's suggestion of using DMODE to change the DNS setting in the /d1
>drive descriptor to DNS=3. I then tried "DIR /d1" and lo and behold, I
>got a directory listing of the root directory of /d1! My euphoria was
>short-lived however, because when I tried doing directory listings of the
>sub-directories CMDS, SYS, and DEFS, the DEFS directory was fine but I
>got an "Error 214" with the CMDS directory and an "Error 247" with the
>SYS directory. It seems to me that Rodney was on the right track. After
>all, before I couldn't read the disk at all, and at least now I can DIR
>the root directory successfully and the DEFS directory. But the disk is
>still basically unuseable. I have also tried Rodney's suggestion of
>alternatively patching LSN0 to change the DD.FMT value from $07 to $03
>with pretty-much the same results as the DMODE fix. Anyone else have any
>Fred Provoncha
>Stansbury Park, UT
>Coco mailing list
>Coco at maltedmedia.com

More information about the Coco mailing list