[Coco] Hard Drive Problems

Mark Marlette mmarlett at isd.net
Fri Jun 4 07:29:46 EDT 2004

At 10:24 PM 6/3/2004 -0600, you wrote:


Sounds like you are not running the mb_hdb_dd script. You have the wrong 
boot loader. Then did you run LINK after you made the boot disk and backed 
it up to drive 255? I would pick drive 254 then try it out, then when it is 
working then go back to 255. Nice to always to be able to boot and go back.

If you can boot to your drive via floppy, then do a dcheck /h0, see if your 
system is intact. Then you will know if your HD is fine.

I'm including the script in case you have a different version.

Substitute 255 with 254 to have a backup version till you have a working 
copy. OR just boot from the floppy you are making till you have it down. 
Should work the first time.....

echo This script creates an HDB-DOS based boot disk
echo that contains SuperSCSI drivers.
echo This boot disk will boot directly to SCSI ID 0
echo when copied to an HDB-DOS virtual disk and
echo properly linked with LINK.BAS.
echo Please insert a blank floppy into /d0
pause and press a key to start the process.
echo STEP 1: Formatting the floppy disk.
format /d0 1 '35' "OS-9 HDB-DOS Boot" r
echo * Step 2: Create a custom boot track
merge ../MODULES/BOOTTRACK/rel_80 ..../MODULES/SUPERSCSI/L2/boot_id0_tc3_l2 
echo *
echo * Step 3: Create the bootfile and boot track
os9gen #32k /d0 -t=bttemp<../BOOTLISTS/superscsi_hard.bl
del bttemp
echo The process is complete. You now have a bootable
echo floppy disk in /d0. Be sure to copy it to your
echo virtual disk on your hard drive under HDB-DOS and
echo link to it with LINK.BAS.

Once this is done from HDB-DOS, RESET the COCO, let the system boot to 
HDB-DOS, type DRIVEOFF, type BACKUP 0 to 255. Then RUN"LINK:4(This is where 
Cloud-9 places then HDB-DOS distyribution disk)

DRIVE is 255........follow the prompts.....



>Hello everyone,
>Well, I'm moved in to my new house and finally got the Coco system
>unpacked and set up. I fired it up on Tuesday for the first time and
>everything worked fine. I fired it up again yesterday on Wednesday and
>encountered a potentially serious problem. NitrOS-9 would not boot from
>the hard drive. It's as if the OS-9 partition wasn't even there! The
>RGB-DOS partition is working just fine. I can access all 256 virtual
>floppies with no problem. But when I type 'DOS 255' to boot NitrOS-9 from
>the hard drive, the hard drive light comes on, the NitrOS-9 boot screen
>comes up, and all that appears on the boot screen is this:
>'1REL Boot OS9p1 tb'
>...and then the system hangs and the hard drive light goes out. From what
>I know of the OS-9 boot process, it looks like the bootstrap process is
>successfully loading the first part of the kernel from Drive 255 of the
>RGB-DOS partition, but then when it tries to jump over to the OS-9
>partition to get the rest of the kernel in the OS9Boot file, it can't
>find it. Any idea what might be wrong or how to fix it? I hope the OS-9
>partition isn't trashed and that it is somehow recoverable. Any ideas?
>By the way, I do have a NitrOS-9 recovery disk. I booted up NitrOS-9
>entirely by floppy (the boot contains an /h0 descriptor and SCSISYS), and
>then tried a 'dir' to access the hard drive. The system hanged. So even
>when I boot up entirely by floppy I still cannot access the hard drive.
>Fred Provoncha
>Salt Lake City, UT
>Coco mailing list
>Coco at maltedmedia.com

More information about the Coco mailing list