[Coco] Hard Drive Problems

Frederick D Provoncha elderpav at juno.com
Fri Jun 4 00:24:06 EDT 2004

Hello everyone,

Well, I'm moved in to my new house and finally got the Coco system
unpacked and set up. I fired it up on Tuesday for the first time and
everything worked fine. I fired it up again yesterday on Wednesday and
encountered a potentially serious problem. NitrOS-9 would not boot from
the hard drive. It's as if the OS-9 partition wasn't even there! The
RGB-DOS partition is working just fine. I can access all 256 virtual
floppies with no problem. But when I type 'DOS 255' to boot NitrOS-9 from
the hard drive, the hard drive light comes on, the NitrOS-9 boot screen
comes up, and all that appears on the boot screen is this: 

'1REL Boot OS9p1 tb'

...and then the system hangs and the hard drive light goes out. From what
I know of the OS-9 boot process, it looks like the bootstrap process is
successfully loading the first part of the kernel from Drive 255 of the
RGB-DOS partition, but then when it tries to jump over to the OS-9
partition to get the rest of the kernel in the OS9Boot file, it can't
find it. Any idea what might be wrong or how to fix it? I hope the OS-9
partition isn't trashed and that it is somehow recoverable. Any ideas?

By the way, I do have a NitrOS-9 recovery disk. I booted up NitrOS-9
entirely by floppy (the boot contains an /h0 descriptor and SCSISYS), and
then tried a 'dir' to access the hard drive. The system hanged. So even
when I boot up entirely by floppy I still cannot access the hard drive.

Fred Provoncha
Salt Lake City, UT

More information about the Coco mailing list