[Coco] [Color Computer] Creating a DSK file on a real coco..

Robert Gault robert.gault at worldnet.att.net
Tue Dec 27 10:54:00 EST 2005

The errors indicate that the disks in question could not be read for 
some reason. Reading one track at a time rather than one sector at a 
time may be putting more stress on marginal hardware. The second disk 
failed after reading one track $1200/$100/$12=1, the first disk at 

If the entire disk had been read, the error would not matter because you 
would still have an image. If dcheck does not show any errors 
(presumably on the original floppies), the only thing I can think of is 
that the "disk" receiving the image failed. Most likely problem is that 
you are using a RAM disk and ran out of room. You need a large RAM disk 
for this process.

George Ramsower wrote:
> ----- Original Message ----- From: "Robert Gault"
> Sent: Sunday, December 25, 2005 5:35 PM
>> I don't know why you are having trouble so I decided to test the 
>> method on my system. I slightly modified the basic09 program to make 
>> it run as fast as possible. That was done by grabbing one track at a 
>> time rather than one sector. The program was also PACKed so that it 
>> ran with runB, faster than the original in Basic09.
>> Note that the program asks for an acceptable MESS extension and 
>> automatically adds @ to the originating drive name.
>> The program was run on a hard drive system and the image file was 
>> checked with ded. The image was an exact duplicate of the disk (double 
>> sided 40 track). The file was transfered to my PC using OSTerm and 
>> HyperTerminal. Average baud was 10100 and the transfer took about 6 
>> minutes. The resulting file was an exact duplicate of the original and 
>> booted using MESS.
> Yep! That one worked! I copied my coco's boot disk(720K 3.5) to an image 
> and it booted in mess. But I neglected to remember that this used 
> ddh0.dd and of course, it didn't really work once os9 began looking for 
> the hd. DOH!
> So started over with a boot I use on a floppy coco(720K 3.5). vimage got 
> part way through and errors out with a 203. Bytecount A200
> I tried an original os9 L2 disk(backed up to a 3.5 ss35trk) and same 
> error. Byte count 1200
> dcheck shows no errors(for what that's worth) Both disks boot and work 
> fine.
> Any ideas?
> George
>> Here is the basic09 program.
>> PROCEDURE vimage
>> DIM inpath,outpath,ext:BYTE
>> DIM track(4608):BYTE
>> DIM vfile,drive:STRING[30]
>> INPUT "Emulator image name; no extension: ",vfile
>> INPUT "Select extension; 1=.dsk, 2=.os9: ",ext
>> UNTIL ext=1 OR ext=2
>> IF ext=1 THEN
>> vfile=vfile+".dsk"
>> vfile=vfile+".os9"
>> INPUT "Disk to copy; ex. /d0: ",drive
>> drive=drive+"@"
>> CREATE #outpath,vfile:WRITE
>> OPEN #inpath,drive:READ
>> GET #inpath,track
>> PUT #outpath,track
>> UNTIL EOF(#inpath)
>> CLOSE #inpath,#outpath
>> END
>> -- 
>> Coco mailing list
>> Coco at maltedmedia.com
>> http://five.pairlist.net/mailman/listinfo/coco

More information about the Coco mailing list