[Coco] [Color Computer] Creating a DSK file on a real coco..

Bob Devries bdevries at gil.com.au
Sun Dec 25 17:06:23 EST 2005

George, skipping the first 4 blocks of the disk in the B09 programme is not 
the answer. You'll find that those 1024 bytes were put there when you 
created the .dsk file (I guess you did this using the MES create command in 
the devices pull-down?)

Try mounting a copy of an existing dsk file that has the same size as the 
one you're trying to create. If you don't have one, yell, and I will help 
with that.
Regards, Bob Devries, Dalby, Queensland, Australia

Isaiah 50:4 The sovereign Lord has given me
the capacity to be his spokesman,
so that I know how to help the weary.

website: http://www.home.gil.com.au/~bdevasl
my blog: http://bdevries.invigorated.org/

----- Original Message ----- 
From: "George Ramsower" <Yahoo at DVDPlayersOnly.com>
To: "CoCoList for Color Computer Enthusiasts" <coco at maltedmedia.com>
Sent: Monday, December 26, 2005 7:57 AM
Subject: Re: [Coco] [Color Computer] Creating a DSK file on a real coco..

> From: "Robert Gault"
> Sent: Sunday, December 25, 2005 10:55 AM
>> The extension .os9 should have worked. Since it did not, there is doubt 
>> that the image file is good. Do you have a Windows program that will do a 
>> raw read of files and display the content as dEd does under OS-9? If you 
>> do, you should look at the testing.os9 image to verify that it looks like 
>> an OS-9 disk.
>> Actually there are 3 things to check. 1) Check the file created on your 
>> Coco using dEd. It should be the same as dEd sees on the real disk. 2) 
>> Make sure that the data transfer process from the Coco to the PC worked 
>> without garbling the contents of the file. 3) Check the file contents on 
>> the PC with a raw file editor.
>> To expand on point #2, I use the OS-9 program OSTerm, an RS-232 pak, and 
>> HyperTerminal to transfer files between my OS-9 coco and Windows PC. The 
>> Coco transfer rate is set to 19200 and Batch y-modem format is used. 
>> HyperTerminal is set for 19200, VT100, y-modem transfers. Make sure your 
>> settings are compatable between Coco and PC in similar fashion.
> Okay, I studied the file and found there was a difference. The B09 
> generated file had 1024 bytes of stuff in the beginning of the file that 
> the disk does not.
> So I modified the routine to throw away the first four blocks of ... 
> whatever it was.
> Then I got a file that looks just like the disk. I used DED to look at the 
> disk and DUMP to look at the file.
> This done, I transferred the file to MESS and now I get a NO PERMISSION 
> error when I try to read it from OS9 in MESS
> The ATTR is  ----r-wr
> I tried to change it to d-ewrewr without success.
> This is (at least) a step in the right direction. At least now OS9 can see 
> it's there.
> Here's the current version of the B09 routing:
> DIM inpath,outpath:BYTE
> DIM block(256):BYTE
> DIM vfile:STRING[30]
> DIM drive:STRING[30]
> INPUT "emulator file.",vfile
> INPUT "Disk to read from >/Dx@ ",drive
> CREATE #outpath,vfile:WRITE
> OPEN #inpath,drive:READ
> FOR x=1 TO 4
> GET #inpath,block
> NEXT x
> WHILE NOT(EOF(#inpath)) DO
> GET #inpath,block
> PUT #outpath,block
> CLOSE #inpath,#outpath
> -- 
> Coco mailing list
> Coco at maltedmedia.com
> http://five.pairlist.net/mailman/listinfo/coco
> -- 
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.371 / Virus Database: 267.14.7/214 - Release Date: 23/12/2005

More information about the Coco mailing list