[Coco] Re: Re: Hard Drive Problems

Frederick D Provoncha elderpav at juno.com
Tue Jun 22 00:42:35 EDT 2004

Okay, time for another update everyone:

The program 'dskwrite' that Willard shared with me doesn't seem to work.
I'm getting 'No Permission' errors every time I run it. The reason didn't
take long to figure out. When the program prompts the user to enter the
name of the disk to write to, I enter "/d0". The program then tries, in
the second OPEN statement, to open a path to a file named "/d0". That of
course is the root directory, not a file, and you can't write to a
directory, so that triggers a 'No Permission' error. I don't think
there's anything I can do about that.

On another front, I tried once again to create a NitrOS-9 boot disk using
the downloaded .dsk files and the DSKINI utility. I ran DSKINI using the
command 'dskini /D /T40 NOS963~1.DSK' from the MSDOS prompt on my x386 PC
equipped with a 3 1/2" and a 5 1/4" drive, using as DSDD 5 1/4" disk. I
then tried to boot from it and as always the boot failed. I then examined
the boot disk sector-by-sector using a utility program called The Zapper'
that was distributed by CocoPro years ago. The Zapper works almost
identically to the utility Ded. The only difference is that instead of
analyzing a file sector-by-sector, The Zapper analyzes a DISK
sector-by-sector. While I had The Zapper running, I opened up another
window and, using the 'PCDOS' utility, I copied the file NOS963~1.DSK
from a PC-formatted 720k 3 1/2" disk over onto my Coco's hard drive. Then
I examined it using Ded. So flipping back and forth between windows (I
love multi-tasking under OS-9!), I compared the file and the disk
sector-by-sector. This is what I found:

Boot Disk Track        Corresponds to...        NITROS963~1.DSK Track
... and so on. You get the idea. There's a pattern here. DSKINI isn't
copying the tracks from the file to the disk correctly. Instead of
copying tracks 0 & 1 from the file over to tracks 0 & 1 of the disk like
it should, it's copying track 0 of the file onto tracks 0 and 1 of the
disk. Then it jumps to track 2 of the file and copies it to track 2 & 3
of the disk. That's not right.

I analyzed the NOS963~1.DSK file using Ded, and there appears to be
nothing wrong with the file. I believe the problem is with the DSKINI
utility. It doesn't seem to be performing right.

What's weird is that no one else seems to be reporting this problem. Why
am I the only one (apparently) experiencing it?

Fred Provoncha

On Fri, 18 Jun 2004 23:18:02 -0600 Willard Goosey <goosey at virgo.sdc.org>
> >Date: Thu, 17 Jun 2004 19:44:47 -0600
> >From: Frederick D Provoncha <elderpav at juno.com>
> >Would it be possible for you to email me the dskwrit program? I 
> can't
> >find it on RTSI.
> >
> OK, here it is:
> PROCEDURE dskwrite
> DIM inpath,outpath:BYTE
> DIM block(256):BYTE
> DIM vfile:STRING[30]
> DIM drive:STRING[30]
> INPUT "emulator file:",vfile
> INPUT "disk to write to (os-9 format ss 35 track):",drive
> OPEN #inpath,vfile:READ
> OPEN #outpath,drive:WRITE
> FOR count=1 TO 630
> GET #inpath,block
> PUT #outpath,block
> NEXT count
> CLOSE #inpath,#outpath
> END 
> Note that it is set up for single-sided disks.  I'm not sure if it
> could easily be expanded for double-sided.  That would depend on 
> the
> sides of the virtual disk being recorded in the same order as the
> physical disk, and off the top of my head I'm not sure how OS-9
> handles that....
> I didn't write this, not my code, works for me, YMMV. 
> Willard
> -- 
> Willard Goosey  goosey at sdc.org
> Socorro, New Mexico, USA
> "I've never been to Contempt!  Isn't that somewhere in New Mexico?"
>    --- Yacko
> -- 
> Coco mailing list
> Coco at maltedmedia.com
> http://five.pairlist.net/mailman/listinfo/coco

More information about the Coco mailing list