[Coco] [Color Computer] Creating a DSK file on a real coco..

Bob Devries bdevries at gil.com.au
Fri Dec 23 21:56:45 EST 2005

George, change this line:

OPEN #outpath,vfile:WRITE


CREATE #outpath,vfile:WRITE

Sorry, my bad, I missed that.

It is important that you use '/d0@' when you canswer the question "disk to 
read from...."

Regards, Bob Devries, Dalby, Queensland, Australia

Isaiah 50:4 The sovereign Lord has given me
the capacity to be his spokesman,
so that I know how to help the weary.

website: http://www.home.gil.com.au/~bdevasl
my blog: http://bdevries.invigorated.org/

----- Original Message ----- 
From: "George Ramsower" <Yahoo at DVDPlayersOnly.com>
To: "CoCoList for Color Computer Enthusiasts" <coco at maltedmedia.com>
Sent: Saturday, December 24, 2005 12:25 PM
Subject: Re: [Coco] [Color Computer] Creating a DSK file on a real coco..

> ----- Original Message ----- 
> From: "Bob Devries" Sent: Friday, December 23, 2005 4:56 AM
>> Here's a modified version to read the disk in RAW mode, and write a .dsk 
>> file:
>> PROCEDURE dskcreat
>> DIM inpath,outpath:BYTE
>> DIM block(256):BYTE
>> DIM vfile:STRING[30]
>> DIM drive:STRING[30]
>> INPUT "emulator file:",vfile
>> INPUT "disk to read from (must have format /DX@):",drive
>> OPEN #outpath,vfile:WRITE
>> OPEN #inpath,drive:READ
>> WHILE NOT(EOF(#inpath)) DO
>> GET #inpath,block
>> PUT #outpath,block
>> CLOSE #inpath,#outpath
>> END
>> --
>  When I first ran this, I received an error 216. DOH! I should have seen 
> that one coming..
> I don't know if it makes any difference how the file is created, but I 
> used "display >filename" and then "dump filename". It appeared to be an 
> empty file.
> Then I ran the B09 program again and it appeared to work. I got the file, 
> transferred it to this XP box, ran MESS and attempted to boot from it and 
> I got the familiar "OK" prompt.
>  Next I booted with another image, mounted this file as /d1 and tried to 
> look at it....
> Error 249
> So I checked the Dmode on the /d1 driver and it was good.
> Then I did "attr /d1" and got no report.
> Then I did "attr /d1 d-ewrewr" and looked at it again and there still was 
> no report.
> Then I tried to format this file and after it did the write, it came back 
> and errored every sector.
> Any suggestions?
> BTW... At 2400 baud, using xmodem it took 57:35 to download to this XP 
> box. I'm going to play with higher baud rates and different protocols to 
> see what would be the fastest way to do this sort of thing. I don't 
> transfer much between the coco and this XP box, I just use hyperterm to 
> operate the coco because the coco is in a room that does not lend itself 
> to a sit down session. Keyboard familiarity and comfort is good. OS9 is 
> perfect for this scenario.....
> George
> -- 
> Coco mailing list
> Coco at maltedmedia.com
> http://five.pairlist.net/mailman/listinfo/coco
> -- 
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.371 / Virus Database: 267.14.7/214 - Release Date: 23/12/2005

More information about the Coco mailing list