[Coco] Re: using Tandy FD drives in a PC

Richard E. Crislip rcrislip at neo.rr.com
Sat Jun 5 22:35:30 EDT 2004

Hello Charlie

That coincides with what I have heard. Newer PC FD controllers do not work
with the olf CoCo floppy drives. You did what you had to do when you
obtained the older PC.

On 06/04/04, Charlie wrote:
> The FD-501 drive worked perfectly in the 486 system. I was able to 
> format and read, write 180K disks under DOS and Anadisk worked great.
> I was able to copy COCO disks and they worked great. However anadisk 
> did not copy the COCO3 Sundog copy protected games. Sinistar, Warrior 
> King, Quest for Thelda all copied but didn't work the same as if I 
> had just done a BACKUP 0 TO 1 in the COCO itself.
> Anadisk was able to copy the COCO2 game White Fire of Eternity and I 
> believe that is copy protected. I'll have to try other games tonight.
> So in the end, I'm still not able to make backups of my favorite COCO 
> games :(
> -Charlie
> --- In ColorComputer at yahoogroups.com, "Mike Pepe" <lamune at d...> wrote:
>> The reason your drives are both being selected at the same time has 
> to do
>> with a quirk of PC floppy cabling. It has nothing to do with the 
> age or cpu
>> type or speed of the PC you're using.
>> All PC floppies are shipped from the factory set as "drive 1". (or 
> is it 2?
>> I'm not sure now) The twist in the cable determines which actual 
> drive
>> select line goes to the proper drive. Thus, you plug a drive into 
> the first
>> connector and it's "A", the second is "B".
>> There are two ways to solve this:
>> 1- use the PC cable, but set your CoCo drive to DS1 (or 2, if 1 
> doesn't
>> work) or:
>> 2- use a straight through cable without the twist. Set your A drive 
> to DS0
>> and your CoCo drive to DS1
>> Don't forget to remove or disable the termination on the drive 
> that's not at
>> the end of the chain.
>> I'm pretty sure the FD-501 drive has drive select jumpers, but if 
> it does
>> not, as you discovered, you can connect it as the only drive and it 
> should
>> work in any PC. You may need to experiment with the twisted/non-
> twisted
>> sockets and whether the PC thinks it's drive A or drive B.
>>> -----Original Message-----
>>> From: Charlie [mailto:chazbeenhad at h...]
>>> Sent: Thursday, June 03, 2004 8:57 AM
>>> To: ColorComputer at yahoogroups.com
>>> Subject: [Color Computer] Re: using Tandy FD drives in a PC
>>> --- In ColorComputer at yahoogroups.com, Robert Emery
>>> <theother_bob at y...> wrote:
>>>>>   ----- Original Message -----
>>>>>   From: Charlie
>>>>>   I could NOT get the FD-501 drive to work as drive B on any 
> of 3
>>>>>   different PCs last night.
>>>>>   1st of all, as it was with a 1.44 floppy on the ribbon cable
>>> both
>>>>>   drives acted as A at the same time.
>>>>>   Any tips on getting this 180K fd-501 disk to work on a PC?
>>>>>   -Charlie
>>>> --- sadolph <sadolph at m...> wrote:
>>>>> There is a resistor network that needs to be uninstalled, on 
> the
>>> b drive I
>>>>> believe.
>>>>> Also, you have to jumper the drive to be drive b.  there are
>>> usually markings
>>>>> that identify which jumper it needs to be.
>>>> If your cable allows it, try putting both drives on the same 
> side
>>> of the twist
>>>> (if you can't find the DS jumpers.) The terminating resistor
>>> network should be
>>>> removed if it's not the last drive on the cable.
>>>> Bob
>>> Yesterday I did get the FD-501 drive working in a Asus A7a-266 
> mobo
>>> with an Athlon 900 cpu running DOS.
>>> My FD-501 drive has no jumpers at all. There is a spot that says 
> DS0
>>> DS1 DS2 DS3 but there are no jumper pins, the DS0 and DS1 are
>>> soldered together. Regardless, It was working as a single drive 
> A. Of
>>> course I told the bios it was a 360K floppy, but I got no error 
> and
>>> Anadisk was writing and reading from the drive just fine.
>>> Still though, at the COCO the disks were no good. No DIR, nothing
>>> just IO errors. I took the FD-501 drive out of the PC and threw in
>>> one of the 360K drives I use on my COCO and got the same results.
>>> So maybe it has to do with the disk controller on the mother 
> board.
>>> Or, a combo of both .....
>>> I guess I'll have to search around here at work for the oldest 
> system
>>> I can find with a 486 or 386 cpu.
>>> -Charlie
> ------------------------ Yahoo! Groups Sponsor --------------------~--> 
> Yahoo! Domains - Claim yours for only $14.70
> http://us.click.yahoo.com/Z1wmxD/DREIAA/yQLSAA/CFFolB/TM
> --------------------------------------------------------------------~-> 
> Brought to you by the 6809, the 6803 and their cousins! 
> Yahoo! Groups Links
> <*> To visit your group on the web, go to:
>     http://groups.yahoo.com/group/ColorComputer/
> <*> To unsubscribe from this group, send an email to:
>     ColorComputer-unsubscribe at yahoogroups.com
> <*> Your use of Yahoo! Groups is subject to:
>     http://docs.yahoo.com/info/terms/
Cruisen                                                    _|_
              on AutoPilot with an Amiga   ---o-( )-o---   and a CoCo

More information about the Coco mailing list